Voce poderia instalar o modulo PHP geoip PECL?

Infelizmente, por razões de segurança, o PECL não pode ser instalado em nossos servidores. Mas você pode utilizar o geoip database padrão para seu scripts PHP.

Faça alguém feliz hoje!